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1. Notes 

1. Notes 

This user manual is a guide to the research product BESA MRI – a stand-alone software program. 

The manual introduces the features, workflows, and the main windows and dialogs of the BESA MRI 
software. A help function is provided within the software. Press F1 on the keyboard or select the menu 
item Help → BESA MRI Help for help. 

Before starting to work with BESA MRI, please read this user manual carefully. 

Please report any suggestions and errors found in this manual via email to feedback@besa.de 

BESA GmbH provides support to all customers who have purchased BESA MRI directly from our sales 
office (sales@besa.de) or through our distributors. 

BESA GmbH 
Freihamer Str. 18 
82166 Graefelfing - Germany 

In case of support requests please contact us at http://www.besa.de/contact/support/. 

Symbols 

 

 

Follow the instructions in this manual to prevent damage resulting from misuse 
of the program. In addition, this symbol marks important sections that shall be 
read before starting to work with BESA MRI. 

 

This symbol indicates potential risks for users of BESA MRI or third parties if 
the product is not used as intended. 

mailto:feedback@besa.de
mailto:sales@besa.de
http://www.besa.de/contact/support/
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2. Start the program 

 

Start BESA MRI using the shortcut created on the desktop or run BESA MRI 
from the Start → BESA → BESA MRI 3.0 folder in Startup menu. 
First, the Welcome Screen appears (see chapter 6.1.1). Press Accept to start 
BESA MRI. 

2.1. Specify the BESA MRI Data Folder 

As initial configuration step, the BESA MRI Data Folder must be specified (for details see User manual 
chapter How to use BESA MRI). This is the folder where BESA MRI stores all project and result data to 
and reads from (typically on the server). 

When starting the program for the first time, the following dialog box appears: 

 

The BESA MRI Data Folder is preselected to Public Users on the local PC (shown above for Windows 
10). However, it is recommended to create the BESA MRI Data Folder on your server where it is 
accessible to all BESA MRI users from anywhere in the local network.  

 

For more details, see User Manual chapters How to use BESA MRI / Import Dialogs / Select the BESA 
MRI data folder (6.4.1) and Appendix / The BESA MRI data folder (7.1). 

 

Press the OK button if you want to use the preselected local folder in All Users. 

Press the Edit button to create your BESA MRI Data Folder elsewhere, e.g. on a server. 

When the selection is accepted, the following confirmation dialog appears: 

 

Important note: For clinical use, it is highly recommended to create the BESA MRI Data 
Folder on an encrypted medium since the data folder can contain patient information. 
Furthermore, please ensure that PCs running BESA MRI are password-protected in this case. 



2. Start the program 

Press the OK button. 

BESA MRI is now configured to start projects. 

 

Notes: The procedure to define the shared BESA MRI Data folder on the server needs to be carried out 
only once at each PC where you install BESA MRI, i.e. when starting the program for the first time. 

When switching between BESA MRI Data folders, it is recommended to leave the tick mark on to update 
all existing projects in the new BESA MRI Data folder (see chapter 2.1). 
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3. Introduction 

3.1. Features of BESA MRI 

The BESA MRI software provides optimized, user-guided workflows to read and transform MRI data to 
ACPC- and Talairach space, reconstruct the scalp and cortical surfaces, and coregister electrode and 
MEG sensor coordinates as well as skin markers with the individual scalp. 

The key features of the BESA MRI software are: 

• Import of MRI data using an automated DICOM, Analyze or NIfTI reader 

• Easy definition of ACPC- and Talairach points and other markers 

• Automated inhomogeneity correction and reconstruction of individual scalp, skull, CSF and cortical 
surfaces 

• Automatic generation of a 4-layer FEM or a 3-layer BEM model 

• Transformation to ACPC- and Talairach space by direct 3D-spline interpolation of the original MRI 

• Easy coregistration of digitized electrodes, MEG sensors, and skin markers with individual MRI data 

• Morphing of electrodes (e.g. digitized or standard 10-10 system) to the individual scalp 

• Creating electrode coordinates automatically on the individual scalp surface by following the 10-10 
EEG placement rule 

• Computation of leadfield matrix for a given electrode layout (EEG) and/or sensor configuration (MEG) 

• Output of coregistration and MRI files (surfaces, meshes and leadfields) for source analysis 
programs, e.g. BESA Research 

The integrated segmentation workflow quickly guides through the necessary initial steps of data 
preparation from the input of the MRI data to the marking of all reference points. Then, an automatic 
finalization process performs the preset correction, segmentation, and reconstruction steps and presents 
the final results for inspection. It is possible to prepare MRI data of several subjects for segmentation and, 
then, start the automatic finalization of all projects in one step. 

The integrated coregistration workflow quickly guides through the loading of a completed segmentation 
project and of a coregistration file, helps to set fiducial markers, and fits electrodes and/or MEG sensor 
coordinates as well as skin points to the scalp surface for final inspection. 

This workflow concept (see chapter 4) allows for the immediate review of each workstep in the Workflow 
Window (see chapter 5), and for the modification of specific parameters and the recalculation of the 
output data if needed. 

The segmentation and coregistration worksteps are described in detail in chapter 6, along with more 
details on how to use BESA MRI. 

BESA MRI provides a subject-based data management (see chapter 7.3). All results are stored in 
subject-related subfolders. Several segmentation and coregistration projects can be managed for each 
subject. 

3.2. Why FEM or BEM modeling 

 

Important note: FEM or BEM models shall not be calculated and applied in data analysis for 
patients who have previously undergone a brain resection. 



3. Introduction 

For all source analysis techniques, the forward model describes the relation between the electrical 
sources in the brain and the measured EEG / MEG. The forward model includes a description of the 
anatomy of the subject’s head. Usually, the exact properties of the individual subject’s anatomy are 
unknown. This is why the forward model is often a spherical or ellipsoidal model, only describing the head 
anatomy coarsely. In EEG, one-layer models are insufficient, as different head tissues have different 
conductivities, which influence the current flow greatly. This is why EEG forward models usually consist of 
3 (scalp, skull, and brain) or 4 layers (scalp, skull, CSF, and brain) associated with different conductivity 
values. MEG forward models are usually 1-layer spherical models as magnetic fields are assumed to be 
less influenced by conducting tissues. 

If a subject’s MRI is available, it is possible to use individual anatomical information for the generation of 
the forward model. Thereby, the forward model becomes more tailored to the individual subject and in 
consequence the inverse solution can become more precise (Vanrumste et al., 2002; Cuffin 1996; Roth et 
al., 1993).This is especially true (a) for sources in brain regions that are not described well by a spherical 
head model (e.g. basal temporal lobe); (b) when individual heads show deviations from the norm. Thus, if 
the research target is to achieve maximal localization precision, an individual realistic head model is 
strongly recommended. 

There are different approaches to realistic head modeling. BESA MRI offers two different head model 
types: Finite Element Method (FEM) and Boundary Element Method (BEM). 

• FEM modeling: It allows modeling cerebro-spinal fluid (CSF) and arbitrarily complex geometries. In 
contrast to 3-layer realistic head models, 4-layer FEM models gain additional precision, as the 
CSF layer is associated with yet another conductivity value than the other head tissues 
(Baumann et al., 1997). Neglecting CSF for EEG forward modeling can lead to larger localization 
errors (Ramon et al., 2003; Wendel et al., 2008). 

o The FEM modeling in BESA MRI was developed in cooperation with the research group 
around Prof. Carsten Wolters. Detailed literature on the methods can be found in the 
reference section (see chapter 8). 

• BEM modeling: The BEM model implemented in BESA MRI uses a 3-layer realistic head model 
(scalp, skull, and brain). In comparison to FEM, BEM can be applied for a piecewise constant 
conductivity field, resulting in a simplified description of the head geometry on the boundaries of 
head tissue. To generate nested closed surface meshes, less detailed volume conductor 
segmentation is applied for BEM in BESA MRI. 

o To compute the BEM forward solution, BESA MRI uses the OpenMEEG (Kybic et al., 
2005; Gramfort et al., 2010) which was developed within the Athena project-team at 
INRIA Sophia-Antipolis. The OpenMEEG is used solving forward problems in the field of 
EEG and MEG, and it consists of the symmetric BEM. 
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4.  The Workflow Concept 

BESA MRI uses a modern workflow concept that guides you through all the worksteps needed to 
complete a project, suggests and explains necessary inputs and user actions, and performs many 
worksteps automatically. At any time, you may interrupt and inspect earlier worksteps or redo them with 
modified input parameters if required. 

 

The workflow window at the left of the BESA MRI screen shown above depicts all the steps of the 
workflow in a segmentation project – completed up to the segmentation of the cortical surface. 

A workflow consists of a series of worksteps that have to be done to finalize a project. Each workstep 
realizes a set of user interactions needed to achieve the workstep-specific result. Some worksteps can be 
run in automated processing mode with preset parameters, e.g. inhomogeneity correction and 
segmentation. Thus, only a few user interactions are needed during the initial worksteps.  

When pressing the Next button or hitting Space a workstep is terminated and the next workstep is 
loaded. Thus, the workflow of a project proceeds sequentially workstep by workstep. 

As described in chapter 5, the layout of the BESA MRI screen is optimized for this workflow concept. The 
workflow menu - as shown on the left in the Workflow Window - gives an overview over all the 
worksteps to be done in the selected project (see chapter 5). The workflow menu can be used to switch 
between the worksteps. For example, you may redo an earlier step with different or advanced parameters 
and continue with automatic processing of all subsequent steps as defined before.  

The current results during a workstep are shown in the Main Window in the middle (see chapter 5.2). 
The Information Window below (see chapter 5.4) provides advice and help information for the current 
workstep. 

During each workstep a special dialog is shown in the Interaction Window on the right to allow for 
optimized user interaction relevant for the current workstep (see chapter 5.3). The interactions required 
during a workstep are grouped starting at the top and ending at the bottom of the Interaction Window. 
After completing all interactions, press the Next button at the bottom or hit Space to proceed to the next 



4. The Workflow Concept 

workstep. Press the Previous button to go back one workstep. After completing the last workstep of the 
workflow, press the Finish button at the bottom of the Interaction Window to save all data created during 
the project. This allows reloading the full workflow of a project with all worksteps at any time later. 

BESA MRI offers two different workflows associated with the following projects: 

• Segmentation Project: Initiated by Start New Segmentation Project (see chapter 6.2.1). 

• Coregistration Project: Initiated by Start New Coregistration Project (see chapter 6.2.2). 

A project is defined by a specific workflow together with the stored individual input and output data. 
Therefore, projects are identified by the name and birth date of an individual subject along with the type of 
workflow specific for the project, i.e. Segmentation or Coregistration. 

Stored projects can be viewed by selecting the menu item File → Open Project, using the open button in 
the toolbar, or pressing the Open Segmentation / Coregistration Project buttons on the start screen. 
After opening a stored completed project, the final workflow result is displayed in a special viewer 
workstep (see screen below for a Segmentation project): 

 

To modify the project or to review the completed worksteps, reload the workflow by pressing the Modify 
button. 
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5. Elements of the BESA MRI Screen 

The layout of BESA MRI screen is optimized for the workflow concept as described in chapter 4. The 
figure below shows the BESA MRI screen with all its elements: 

 

 

① Workflow Window (see chapter 5.1) 

② Main Window (see chapter 5.2) 

③ Interaction Window (see chapter 5.3) 

④ Information Window (see chapter 5.4) 

⑤ Menu Bar (see chapter 5.5) 

⑥ Title Bar (see chapter 5.6) 

⑦ Toolbar (see chapter 5.7) 

⑧ Caption (see chapter 5.8) 
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5.1. Workflow Window 

The Workflow Window on the left displays the workflow menu. The workflow menu gives an overview 
over the sequential steps needed to finish the current project (for details on the steps see chapter 6.2). 
Steps already completed are marked with a green OK sign ( ) 

The current workstep is highlighted. This step is also shown in the caption. 

The workflow menu can be used like any other menu to jump to another workstep provided that the 
previous worksteps have already been completed. 

5.2. Main Window 

The Main Window area displays the results of the current workstep. A detailed description how to use the 
elements shown in this window is given in chapter 6.3. 

5.3. Interaction Window 

The Interaction Window provides the user interaction for the 
current workstep. In some worksteps a red marker illustrates 
the current interaction to be done at the top of the Interaction 
Window. 

The upper interaction elements are used to set parameters 
needed in the workstep by using standard elements like 
buttons, edit boxes, and sliders. The effect of changing 
parameters is seen in the Main Window left of the Interaction 
Window.  

The substep buttons below describe the substeps to be taken 
within the workstep. The current substep is highlighted. After a 
step is completed, a green OK sign appears beside the 
corresponding substep button. 

Current parameters are accepted by hitting Space, by pressing 
the Next button at the bottom or the next substep button (in this 
example the Set RP (rightmost point) button).  

Thus, the workflow proceeds to the next substep or workstep 
automatically. 

The Previous button is used to jump back to the last substep or 
to the last workstep, respectively. 

Notes:  

1. Most parameters are set more conveniently by mouse 
interactions with the displays in the Main Window (see 
chapter 6.3). 

2. To change parameters of a completed substep, unpress the 
corresponding interaction button. 

3. You can undo or redo a substep or workstep also using the 
menu items Edit → Undo and Edit → Redo or by typing 
Ctrl-Z or Ctrl-Y. 

4. Moving on to the next substep or workstep is fastest by 
hitting Space or Enter. 
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5.4. Information Window 

The information window displays a comprehensive help text related to the current workstep. The help 
texts provide additional information, e.g. which file has been loaded. They suggest and explain the next 
user interaction to be done in the current workstep. 

Underlined text in blue provides a hyperlink. Click on such a link to open the BESA MRI help at the 
indicated topic. 

5.5. Menu Bar 

The Menu Bar provides the menus listed below. Click on a menu to be selected and choose from the 
menu items that pop up. 

5.5.1. File Menu  

The File menu contains functions related to the data management (see chapter 7.3). It contains the 
following items: 

File menu item Description 

Create New Project Start a new project. 

Open Project Load an existing project (see chapter 6.4.2). 

Close Project 
Close currently active project. Show the Select Project Page (see 
chapter 6.1.2). 

Save Save the currently active project. 

Save As… 
Specify a filename for currently active project and save it (see chapter 
6.4.3). 

Delete Projects… 
Select one or multiple projects that shall be deleted (see chapter 
6.4.4). 

Select Data Folder 
Select the folder to be used as BESA MRI Data Folder (see chapter 
7.1). 

Update Data Folder Info 
Update the information file in the BESA MRI Data Folder (see chapter 
7.2). 

Exit Terminate the BESA MRI program. 
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5.5.2. Edit Menu 

The Edit menu contains the following items: 

Edit menu item Description 

Undo Undo the last step completed in the current workstep. 

Redo Redo the last step that was undone in the current workstep. 

Finalize Current Project 
Start an automatic finalization of the currently active workflow. This 
menu item is only enabled, after a workflow state has been reached at 
which all data are prepared for automatic finalization. 

Finalize All Segmentation 
Projects 

Start a finalization of all segmentation projects that are prepared for 
automatic finalization and defined in the current BESA MRI Data folder. 

5.5.3. View Menu 

The View menu can be used to change display settings for BESA MRI. It contains the following entries: 

View menu item Description 

Show Workflow Window 
By selecting or deselecting this menu item the Workflow Menu is 
displayed or hidden (see chapter 5). 

Show Information Window 
By selecting or deselecting this menu item the Information Window is 
displayed or hidden (see chapter 5.4). 

Standard Font Size, 
Large Font Size, 
Extra Large Font Size 

Select one of these menu items to specify the size of the font to be 
used in BESA MRI. 

5.5.4. Export Menu  

Use the Export menu to export the current main window as an image file format (*.eps, *.png, or*.svg). 

Export menu item Description 

Main window Open the “Save Image As…” dialog. 

5.5.5. Help Menu  

Use the Help menu to open the program help or to get information about BESA MRI. 

Help menu item Description 

BESA MRI Help Open the program help. 

About… Get information about the current program version. 

5.6. Title Bar 

The title bar of BESA MRI displays the program name and version number. In addition, it shows the 
following information on the current project:  

• Subject information (subject name and birthday) 
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• Project name (if specified) 

• Project type (segmentation or coregistration project) 

5.7. Toolbar 

The Toolbar provides direct access to the most important menu items: 

File → Create New Project 

File → Open Project 

File → Close Project 

File → Save Project 

Edit → Undo 

Edit → Redo 

5.8. Caption 

The caption is located between the Menu Bar and the Toolbar and specifies the current workstep. 
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6. How to use BESA MRI 

Before working with BESA MRI, please read chapter 4 on the workflow concept. Consult chapter 5 on the 
elements of the BESA MRI screen while starting to use the program. 

6.1. Starting BESA MRI 

6.1.1. Welcome Screen 

Start BESA MRI from its icon on the desktop or from BESA Research during the coregistration process. 

When starting BESA MRI, a welcome screen appears. It provides some information on the BESA MRI 
program including the current version number and date: 

 

Press Accept to start BESA MRI. 

 



 6. How to use BESA MRI  

 

17 

6.1.2. The Select Project Page 

After starting BESA MRI, the page Select Project shows. It allows to select a specific workflow: 

 

Press one of the buttons in the Interaction Window on the right to start the desired project and the related 
workflow. 

Press Start New Segmentation to create a new segmentation project. The Segmentation Workflow 
opens (see chapter 6.2.1).  

Press Start New Coregistration to create a new coregistration project. The Coregistration Workflow 
opens (see chapter 6.2.2). 

Press Open Segmentation Project to load an existing segmentation project. If the selected project has 
been finished, the View Results screen opens (see chapter 4).   

Press Open Coregistration Project to load an existing coregistration project. If the selected project has 
been finished, the View Results screen opens (see chapter 4).  

Notes:  

1. Before coregistration can be started for a subject, at least one MRI segmentation project has to be 
finished for this subject. 

2. Projects can also be started or opened at any time by selecting the menu items File → Create New 
Project or File → Open Project. 
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6.2. The Workflows of BESA MRI 

6.2.1. The Segmentation Workflow 

In the Segmentation Workflow, individual MRI data are prepared for the segmentation of different head 
tissues needed for FEM or BEM. Once the head tissues are segmented, a 4-layer FEM model (scalp, 
skull, CSF and brain) or a 3-layer BEM model (scalp, skull, and brain) is generated based on the 
segmented volumes. The FEM or BEM model is directly available for source analysis in BESA Research 
or for exporting to use in third-party software. The Segmentation Workflow consists of the following 
worksteps: 

6.2.1.1. Set Project Targets 

The first workstep gives an overview over the worksteps that have to be done to complete the loaded 
workflow. Grayed tick marks indicate obligatory worksteps, empty checkboxes relate to optional 
worksteps. Please note that if a FEM model or BEM model is to be created, the respective option Run 
Volume Conductor Segmentation for FEM or Run Volume Conductor Segmentation for BEM needs 
to be checked. If an inflated representation of the cortical surface shall be prepared please check the 
option Run Cortex Inflation. 

Hit Space or press Next to continue the workflow. 

6.2.1.2. Read T1-weighted MRI Data 

In this workstep, MRI data are imported. BESA MRI can read DICOM, ANALYZE and NIfTI format. 

 

 

 

DICOM 

Select the subject’s MRI folder and one of the files of the DICOM data set to be processed. BESA MRI 
loads all files of the same imaging sequence stored in the selected folder. Slice data files are read in, 
sorted, and oriented automatically. 

The header information of the DICOM files is evaluated and displayed in the Main Window. Check if 
subject and sequence are correct and hit Space or press Next to continue the workflow. 

 

The MRI data are read and oriented automatically based on the official DICOM standards. To 
avoid left-right permutation, application of a side marker for MRI acquisition is recommended. 

Ensure that the acquisition protocol of the DICOM MRI data produces orthogonal slice 
orientation. 
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DICOM Folder 

If several DICOM scans (of the same or different subjects) are stored within the same folder, the option 
DICOM Folder should be selected in the drop-down menu Files of Type. After selecting the DICOM 
folder, any of the individual DICOM files within the folder can be selected and BESA MRI will open a 
dialogue summarizing all the available scans that can then be individually selected. Proceed with OK. 

 

ANALYZE 

Select the header (*.hdr) file of the subject’s MRI. The Analyze image is then read in automatically. 

NIfTI 

Select the NIfTI (*.nii) or the compressed NIfTI (*.nii.gz) file of the subject’s MRI. The NIfTI image is then 
read in automatically. 

Other data formats 

BESA MRI can import MRI data in Brain Voyager format (*.vmr). However, this format is not supported for 
diagnostic use. Do not use Brain Voyager Data in a clinical setting. 

 

Anonymize data 

Optionally, by pressing the Modify Data Info button the patients name and date of birth can be changed. 
Furthermore, one can also remove the file path from the loaded data. 

 

 

Note: The original MRI data and header information are stored with other project data in an internal 
format in the BESA MRI Data Folder under the subject name and the project name. This allows reloading 
the project data later independently of the original MRI data. 

6.2.1.3. Read T2-weighted MRI data 

Optionally, T2-weighted data can be loaded in this workstep. This is recommended in order to achieve a 
more precise result for skull labeling, as T1 data alone do not allow a good reconstruction of the skull. 
BESA MRI does not require T2-weighted data for creating a FEM model. If no T2-data are available, the 
skull is reconstructed based on the T1 image in combination with internal atlas information. 

For BEM, only T1-weighted MRI data is used for generating volume conductor segmentation. 

 

Important note: The patient name and date of birth are important identifiers. Changing the 
patient name or date of birth is not recommended in diagnostic use. 
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6.2.1.4. Set Orientation of T1 Data 

In this workstep, it is possible to re-orient the MRI data to match with BESA MRI standards as indicated 
by the head schemes in the interaction window. 

 

This should not be necessary for DICOM data but may be required if Analyze or Nifti files are read as 
they often lack information on image orientation. 

Once the orientation is set correctly, it is also possible to flip left and right. This option should only be 
checked if the user is certain that left and right were wrongly assigned. This is why the LR-Correctness 
needs to be confirmed explicitely. 

Hit Space or press Next to continue the workflow. 

6.2.1.5. Set ACPC Transformation 

In this workstep, the transformation of the original data into the ACPC coordinate system is defined by 
marking the middle of the anterior commissure (AC) and rotating the MRI data set to obtain an optimal 
view of the ACPC plane (PC: posterior commissure) and the best separation of both hemispheres by the 
sagittal plane. 

In the first substep, the position of the AC (anterior commissure) is set by dragging the slices in the 
lower half of the Main Window such that the AC midpoint meets the crosshair (for dragging slices see 
chapter 6.3.1). You may also adjust the crosshair in half millimeter steps using the interaction elements in 
the Interaction Window on the right. 

Hit Space or press Next to set and confirm the AC position and continue with the second step. 

In the second substep, ACPC rotation is set by rotating the MRI slices such that a) the PC midpoint 
appears on the crosshair line behind the AC position and b) the sagittal plane separates the two 
hemispheres optimally. Rotation is most easily done by dragging the lower slices in the Main Window 
while checking the upper slices for separation of the hemispheres. You may also use the controls in the 
Interaction Window on the right to set the three rotations, but this is less convenient. 

Hit Space or press Next to confirm the PC position & sagittal plane and continue with the third step. 

In the third substep, the position of the PC (posterior commissure) is set by dragging the lower left slice 
in the Main Window such that the PC midpoint meets the horizontal bar of the crosshair. 

Hit Space or press Next to inspect the final ACPC transformation. Readjust if needed by pressing the 
required substep buttons on the right. 
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Note: The display settings and the zoom factor can be adjusted at any time at the bottom of the 
Interaction Window for optimal viewing of the MRI data. For example, you may increase the zoom factor 
to 2.5 or 3.0, unpress the AC (anterior commissure) substep button to readjust the AC midpoint and 
observe that the following rotation and PC setting steps have been preserved. They can be readjusted in 
the same way to have an optimal definition of the ACPC transformation. 

Hit Space or press Next to continue the workflow and move on to the next workstep. 

6.2.1.6. Set Talairach Transformation 

In this workstep, the brain boundaries have to be set by the user to enable a Talairach Transformation of 
the original MRI. This transformation is needed for various masks during segmentation. 

During this workstep, one of the six brain boundaries is set in each substep. It is easiest to drag the slice 
as listed below while observing the cortical gyri disappear and reappear in the cutoff slice to view: 

Substep to set Drag slice View slice Check cortical boundary at 

AP (anterior plane) Transversal Coronal Frontal brain 
PP (posterior plane) Transversal Coronal Occipital brain 
SP (superior plane) Coronal Transversal Top gyri 
IP (inferior plane) Coronal Transversal Temporal poles 
LP (leftmost plane) Coronal Sagittal Lateral temporal cortex 
RP (rightmost plane) Coronal Sagittal  Lateral temporal cortex 

It can be helpful to click into the outermost gyri in the cutoff slice for better viewing in the other slices.  

Hit Space or press Next to proceed step by step. Follow the instructions in the Information Window. 

6.2.1.7. Set Markers 

In this workstep several markers are set as input for the following automated segmentation worksteps. 

In each substep, Click onto the requested region as described and illustrated below. A red marker 
appears. You may drag this marker to adjust. Hit Space or press Next to confirm the position and 
conclude the substep. The accepted marker is now shown in blue. 

Alternatively, you may Double Click onto the requested region. The marker will appear in blue 
immediately and the workflow proceeds to the next substep. 

Corrections can be made by unpressing any substep button in the Interaction Window on the right and 
hitting Space or pressing Next to continue. For more details on setting or modifying markers see chapter 
6.3.2. 

In the first two substeps, the positions of the nasion and the inion are set. These positions are needed 
for the segmentation of the skull.  

In the third substep white matter is marked in the brainstem and medulla oblongata by three to five 
markers. Set the markers equally spaced from top to bottom. The markers identify the gray values of the 
white matter at the lower portion of the head and are needed as input for the automated inhomogeneity 
correction. Make sure you mark only white matter portions. 

In the last and fourth substep a cutting plane is specified by two markers. All parts below this cutting 
plane will be cut off during Scalp Segmentation. The cutting plane can be moved up and down by 
dragging the left marker. By dragging the right marker, a different cutting angle can be set. 
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In the figure below, the Set Markers workstep is illustrated at its end before confirming the Cutting Plane. 

 

6.2.1.8. Register T2 Image 

In the registration workstep of BESA MRI, a T2-weighted image is registered to the T1-weighted image 
using an affine registration approach. Registration is performed on multiple coarse to fine resolution levels 
to improve convergence and robustness (Maes et al., 1999). Mutual information (Wells et al., 1996) is 
used as a registration measure as it allows the registrations of different image modalities (e.g. T2-
weighted MRI to T1-weighted MRI). 

The automatic registration is run by pressing the Run Registration button. If required one can perform 
manual corrections to the nine transformation parameters describing the translation, rotation, and scaling, 
using the interaction elements right below the Run Registration button. The optional Run Registration 
Step button will perform a very similar procedure to Run Registration, alas with the initial state given by 
the currently set transformation parameters and using a smaller "search radius". I.e. it assumes the 
currently set transformation parameters to be already rather close to the optimal solution. 

The quality of the registration can be evaluated by the user by toggling between the T1 and T2 data sets 
by pressing the Toggle Data Selection button. 

Select the Prepare Volume Data button to confirm the registration parameters and prepare the data for 
the next working steps. 

Hit Space or click Next to continue. 

6.2.1.9. Automatic Finalization 

With the completion of this and the previous worksteps, all steps needing your input have been done and 
the MRI data preparation is complete.  

Therefore, BESA MRI offers the option to continue with the Automatic Finalization of the segmentation 
project or to follow and adjust the segmentation process step by step. For most data sets, adequate 
segmentation output is generated using the default parameters of the Automatic Finalization.  
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Thus, at the beginning of the correction and segmentation worksteps, you have the following options:  

Since the correction and segmentation worksteps take about 20-30 minutes per MRI data set, it is 
recommended to use Automatic Finalization and inspect the results before deciding whether parameter 
adjustment is needed.  

If the default segmentation results are inadequate, you may return to the segmentation worksteps using 
the Workflow Window or by pressing the Previous button. Then, modify the required segmentation 
parameter(s) and continue the segmentation step by step.  

Another advantage of Automatic Finalization is that you can prepare several individual MRI data sets for 
finalization and work on other tasks while all prepared projects are being finalized automatically. It takes 
only about 5 minutes to prepare one MRI data set. 

When automatic finalization is running, it may be interrupted at any time by pressing the Cancel button in 
the progress bar: 

 

The current workstep will be completed automatically, but it can also be canceled at the lower right of the 
Information Window, e.g. to change the number of iterations during inhomogeneity correction. 

When doing correction and/or segmentation step by step, automatic finalization can be restarted at any 
time pressing the F9 key, or by selecting the menu item Edit → Finalize Current Project (or All 
Segmentation Projects). 
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6.2.1.10. Inhomogeneity Correction 

The gray values of the white matter are not homogeneous throughout the brain in typical MRI data. 
Therefore, inhomogeneity correction is needed as a major workstep prior to the segmentation of the 
different brain tissues. In BESA MRI, this correction is done by an automated workstep realized as an 
iterative procedure based on the AFCM (Adaptive Fuzzy C-Means) algorithm enhanced by incorporating 
anatomical template masks. For more details on the AFCM algorithm see Pham et al. (1999). 

For adequate results at least 5 to 10 iterations are needed. By incrementing the number of iterations 
above the default of 10 iterations the correction can sometimes be improved. 

Hit Space or press Next to continue. 

6.2.1.11. Scalp Segmentation 

The reconstruction of the scalp surface is done by segmenting the subject's head from the background 
using a level set algorithm. For more details on this algorithm see (Chan et al., 2001). First, a rough start 
mask is constructed by thresholding the image and using subsequent morphological operations. Based 
on this start mask, level set segmentation on a coarse computational grid is performed. The result of this 
segmentation is then refined using a higher resolution grid. 

For the creation of the initial rough start mask, a gray value threshold is used to select all voxels inside 
the head with higher gray values and to exclude all outside voxels with lower gray values. As default 
threshold for start mask a gray value of 30 is used during automated segmentation. Increase this 
threshold to remove artifacts that might be present outside of the head in the segmented scalp. Decrease 
the threshold if some parts of the subject's head are not adequately reconstructed in the segmented 
scalp. 

The default number of iterations is set to 3 for automated segmentation. Scalp segmentation results 
may be improved by increasing the number of iterations.  

Set smoothness parameter allows handling MRI scanner artifacts. If a lot of unwanted noise is present 
in the background of the MRI images, it can be helpful to increase the smoothness parameter in order to 
prevent the segmentation algorithm from categorizing artifacts as scalp tissue. The default setting is 5.0. 

Both processes, scalp segmentation and refinement have been automated in one segmentation workstep 
combining these two substeps. If you want to improve scalp segmentation after inspecting the 
automatically obtained results, unpress the Run Segmentation button in the Interaction Window, adjust 
the threshold and/or the number of iterations, and press the Run Segmentation button again or hit 
Space to recalculate this segmentation workstep. 

Hit Space or press Next to continue. 

6.2.1.12. Cortex Segmentation 

In this workstep the cortical surface is reconstructed. Optionally, an inflated representation of the cortical 
surface can be generated for visualization purposes. 

The cortical surface is reconstructed in an automatic process consisting of several steps. First, a voxel-
based classification of the white matter is performed. Then, using the level set algorithm, the surface of 
the classified white matter is reconstructed, carefully smoothed and inflated to generate the cortical 
surface. This surface can be used as an approximate source space for cortical source imaging, e.g. in 
BESA Research.  

The inflated representation of the cortex is generated by smoothing out the cortical foldings while 
minimizing metric distortions. The inflation algorithm is based on the work by Fischl et al. (1999). The 
original location of gyri and sulci is indicated by a lighter, respectively, darker gray color. 

Currently, cortical surface reconstruction and inflation are done by fully automated procedures not 
requiring the user to define specific parameters.  

Hit Space or press Next to continue. 

Note: Cortex segmentation and inflation were tested and optimized for a large number of data sets 
acquired on current MRI systems. You are invited to submit any questions or feedback here: 
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https://www.besa.de/support/support-page/, if you are not getting sufficient results with older MRI data 
sets.  

6.2.1.13. Volume Conductor Segmentation 

This optional workstep consists of two sub-steps. First, all four layers (Scalp, Skull, CSF, Brain) are 
labeled. To run this sub-step, press Run Volume Conductor Segmentation. 

 

It is possible to review the segmentation results by changing the Blending factor so that more or less of 
the underlying MRI is displayed. Second, the FEM model is generated based on the segmentation results 
(Wolters et al., 2007) and surface meshes of the 4 tissue layers are extracted. Press Prepare FEM 
meshes to run the algorithm. The meshes are displayed as colored lines. 

The workstep of the volume conductor segmentation for BEM also consists of similar steps. First, all 
three-layers (scalp, skull, and brain) are labeled after pressing Run Volume Conductor Segmentation 
button. Then, the nested closed surface meshes for the three-layers are generated after pressing 
Prepare BEM meshes button. 

 

Hit Space or press Next to continue. 

6.2.1.14. Calculate and Verify Results 

During this workstep, the final segmentation results are calculated and displayed for inspection. 

https://www.besa.de/support/support-page/
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Before finalizing the output, you may adjust the display settings, i.e. the brightness and contrast values, of 
the generated MRI volume data sets if needed. These values have been set to a preset standard during 
the segmentation project. If you need to adjust these values, use the controls at the upper right in the 
Adjust gray scale section of the Interaction Window. While adjusting, inspect the MRI slices in the Main 
Window carefully. 

To use the original MRI volumes instead of the inhomogeneity-corrected MRI volumes, you should check 
the check box MRI without inhomogeneity correction in the MRI options section. 

 

Hit Space or press Next or Calculate Output Data in the Interaction Window to continue. 

The calculation creates the output MRI volumes in ACPC and Talairach spaces using one direct 3D 
spline interpolation of the original MRI data (this way we reduce interpolation errors to a minimum). 
Surfaces are also calculated for both the ACPC and Talairach spaces. 

You may inspect the results in more detail by selecting one of the ACPC, Talairach, or FEM (scalp, skull, 
CSF, or brain) / BEM (scalp, skull, or brain) Head symbol buttons in the Set main window display 
section at the lower right of the Interaction Window. The FEM / BEM results can also be displayed as 
slices overlaying the ACPC MRI. If results are not satisfactory, you may select any previous workstep in 
the Workflow Window, modify specific parameters in the workstep that generated insufficient output, and 
redo the following worksteps manually or using automatic finalization. Use the workflow menu on the left 
to select the workstep to be modified. 

Hit Space or press Finish to complete the segmentation workflow and create the output data. Follow the 
dialogs to save all data of the segmentation project (see chapter 6.4.3). 

This ends the segmentation workflow and the Select Project page appears offering to start a new project 
or open a saved project. 
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6.2.2. The Coregistration Workflow 

The coregistration workflow provides the coregistration of digitized surface points (electrodes and/or MEG 
sensors, fiducials, and skin points) or standard EEG electrodes with an individual MRI data set. 
Coregistration is done by marking the 3 standard fiducials (nasion, left and right preauricular points) on 
the reconstructed individual scalp surface and fitting the fiducials and selected sensors & skin points to 
this surface. 

Standard electrodes can be also matched approximately with an individual MRI. They need to be labeled 
according to the 10-20 or 10-10 international system. 

The coregistration workflow consists of the following worksteps: 

6.2.2.1. Set Project Targets 

The first workstep gives an overview over the worksteps that have to be done to complete the loaded 
workflow. Grayed tick marks indicate obligatory worksteps, empty checkboxes relate to optional 
worksteps. 

To skip electrode and fiducial fit, the check box Skip electrode and fiducial fit needs to be checked. 

When the check box 10-10 electrode placement is checked, electrode coordinates can be automatically 
generated on the subject’s scalp surface following 10-10 placement rules in the Fit Surface Points 
workstep. 

Please note that in case a FEM / BEM model was created that is to be used in BESA Research or for 
exporting, the option Generate FEM EEG Leadfield, Generate FEM MEG Leadfield, Generate BEM 
EEG Leadfield, or Generate BEM MEG Leadfield needs to be checked. 

Hit Space or press Next to continue the workflow. 

6.2.2.2. Set Fiducials 

In this workstep, select an individual subject for coregistration and mark the three fiducials on the scalp 
surface. 

First, choose an individual subject for coregistration by selecting the related segmentation project. At least 
one segmentation project must have been completed for a subject prior to coregistration with MRI. 

To select a project, hit Space or press Next or Select Input Project in the Interaction Window. 

The Select Input Project box opens. Select the subject and one of the projects if several exist. Press OK 
to load the selected segmentation data of this subject as input for coregistration. 

Next, set the Nasion position. Click onto the surface to set the nasion marker. You may adjust by 
dragging the marker with the mouse. 

To confirm the position, hit Space or click Next or Set Nasion. You can also double click. 

The head now turns to show the left side for marking the next fiducial. Click onto the surface to mark the 
left preauricular point. You may adjust by dragging the marker with the mouse. 

To confirm the position, hit Space or press Next or Set Left Preauricular Point. 

The head now turns to show the right side for marking the next fiducial. Click onto the surface to mark the 
right preauricular point. You may adjust by dragging the marker with the mouse. 

To confirm the position, hit Space or press Next or Set Right Preauricular Point. 

Rotate the head to reinspect the positions of the 3 markers (see chapter 6.3.3). Modify, if needed, by 
unpressing the required Set … button in the Interaction Window. 
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The figure below displays the completed workstep. The head is rotated to show both the nasion and the 
left preauricular markers: 

 

Hit Space or press Next to continue the workflow. 

6.2.2.3. Fit Surface Points 

In this workstep, fiducials, electrode / MEG sensor positions, and skin points are loaded from a surface 
head point file (*.sfh), aligned, and optimally fitted to the loaded individual MRI scalp surface. 

Hit Space or press Next to load a coregistration file (*.sfh) of the selected subject created when initiating 
the coregistration process with a selected EEG or MEG data set (e.g. in BESA Research). 

The Open File box comes up. Select the appropriate coregistration file (*.sfh) and open. 

After loading the .sfh file, an initial coordinate transformation is calculated to match and align the three 
fiducials marked on the MRI scalp surface with the fiducial positions stored in the .sfh file. The loaded 
surface positions are displayed taking into account this transformation. 
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In the next step, the loaded coordinates are transformed again using shift, rotation and linear 3D shrinking 
operations to fit electrodes and surface points optimally to the skin surface. For this fitting process, only 
electrodes and surface points higher than A1/A2 (z ≥ -30 mm in the head coordinate system) are 

used while a variable elastic bound is attached to the fiducials to preserve their closeness. 

You can also manually exclude or include electrodes or surface points from the fitting. To do that, right 
click on an electrode and then select Disable for fit / Enable for fit in the popup menu. The shading of 
the point is changed to show that it is excluded from the fitting. 

 

To start the fitting process, hit Space or press Next or Run Surface Point Fit. 

 

Inspect the results by rotating the head, and inspect the positions of the fitted (pink) vs. marked (blue) 
fiducials as well as the right/left symmetry of the electrodes when fitting standard electrodes. The head 
views can be toggled using the button in the section Set default head views. 

If the surface point fit is not adequate, one can manually correct the electrode cap position directly using 
the rotation, translation, and scaling elements in the interaction window. The button Reset Manual 
Correction moves the manual correction back to the defaults. 

Alternatively, one can also tune the automatic surface point by unpressing the button Run Surface Point 
Fit and changing the parameters in Advanced Settings. This can be done either in the upper section of 
the Interaction Window (e.g. to change weights of fiducials vs. electrodes and skin points) or in the lower 
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section (e.g. to modify the strength of the fiducials bound by restraining to a distance smaller than the 
default of 2 mm). 

You might also want to modify the marked fiducials for better matching. To return to the previous 
workstep, press the Previous button or select the Set Fiducials workstep in the Workflow Window on the 
left. For example, if standard electrodes appear asymmetric, it may be helpful to modify the position of the 
preauricular fiducials to improve the symmetry along with increasing the weight of the fiducials (e.g. to 10) 
and decreasing the distance restraint (e.g. to 0.5 mm) in the Advanced Settings of the Fit Surface 
Points workstep. 

After finishing the fitting, you can display final coregistration results 
(the one that are used i.e. in BESA Research) by checking the 
check box Show Finalized Coregistration. In this view, electrodes 
(and only electrodes) are orthogonally projected to the skin surface. 
This option has no effect for MEG sensors, fiducials and other 
surface points. When button is checked all the computation relevant 
buttons are disabled. 

Scalp surface can be toggled using the check box Show Scalp 
Surface 

MEG sensors can be visualized using the check box Show MEG 
sensors after finishing the fitting. 

 

6.2.2.4. Generate Forward Model 

If the option Generate FEM EEG Leadfields, Generate FEM MEG Leadfield, Generate BEM EEG 
Leadfields, or Generate BEM MEG Leadfield is checked under Set Project Targets, BESA MRI will 
calculate leadfields for the given electrode / sensor layout in this workstep. The leadfield information can 
then be used directly in BESA Research for source localization. 

It is possible to use default conductivity values for different age groups (available from the drop-down 
menu Select pre-defined conductivities after checking the check box Use predefined conductivities) 
or to manually adjust conductivity settings for scalp, skull, CSF, and brain. The conductivity value for CSF 
is used for FEM. 

When the checkbox Use adaptive integration in the BEM options section is checked, adaptive 
integration is applied in BEM leadfield computation. The leadfield vectors for a source close to a brain 
surface can be estimated more accurate when adaptive integration is applied, but the computation time is 
increased. 
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Please note that this step can take a while to compute, depending on the number of electrodes / sensors 
in the channel layout. For FEM, the electrode / sensor, for which the leadfield is currently computed is 
highlighted in orange, and the electrodes / sensors that are already finished are displayed in blue. 

Hit Space or press Finish to complete the coregistration workflow. Follow the dialogs to save all data of 
the coregistration project (see chapter 6.4.3). 

 

Notes: 

• The loaded coregistration file will be modified, i.e. the current coordinate transformations and MRI 
output file information are added to the end of the file when saving the project. When refitting with 
modified parameters, and saving, it is modified again. 
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6.3. User Interaction in Main Window 

The Main Window is used to display the results of the current workstep. In addition, it may be used for 
user interactions like setting positions in volume data or markers onto surface data. These user 
interactions are described in detail in this section. 

6.3.1. How to use the Slice Displays 

Slice displays are used for depicting MRI volume data. These displays show three orthogonal cross-
sections of the MRI data set, i.e. the transversal (Tra), coronal (Cor), and sagittal (Sag) slices. A red 
crosshair line marks the plane where two slices intersect. The slice center is the 3D position where the 
three slices – and the three crosshairs - intersect. In the upper row, the three slices are shown fully, 
centered relative to the midpoint of the MRI data set. In the lower row, zoomed slices are shown, 
centered at the slice center. 

Thus, in the upper row, the slice center and the crosshair can be moved by clicking onto the slice or 
dragging the crosshair. In the lower row, the crosshair (and slice center) is fixed relative to the display 
frame and the slices move when clicking or dragging. 

In BESA MRI, several 3D positions need to be set in the volume data (e.g. the AC & PC positions). You 
may approximate such positions by clicking on the slice displays in the upper row and do fine adjustments 
by dragging the lower slices to the desired position. 

The mouse wheel can be used to move to the next/previous slice. 

Some positions require adjustment only in one dimension, e.g. the setting of the PC position below AC in 
the transverse slice or the Rotation of a selected slice. Therefore, the effects of clicking or dragging will 
be limited to the allowed dimensions. 

When moving the mouse over a slice display, the mouse cursor symbol signals the available interaction 
associated with clicking or dragging: 

 No  dragging possible. Rotate the slice (around fixed mid-position). 

 Click to set slice center (anywhere in slice). Move the slice. 

 Click to move slice center (only up-down). Move the slice (only left-right). 

 Click to move slice center (only right-left). Move the slice (only up-down). 
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6.3.2. Setting Markers in Slice Displays 

Slice displays can also be used for setting markers at specific positions. 

A marker is set in a slice display by a single click onto the desired position in the slice. A marker can be 
selected by clicking onto it and it can be moved within a slice by dragging the mouse. Selected markers 
can be removed by pressing the Del key. 

The mouse cursor symbol specifies which marker interactions can be done at a specific position: 

  Set marker. 

 Select or move marker under cursor. 

 

6.3.3. How to use 3D Surface Displays 

The 3D surface displays are used to show the surfaces reconstructed by BESA MRI. 

The 3D surface images can be rotated by dragging the mouse. They can be moved / zoomed by dragging 
the mouse while holding down the Ctrl / Ctrl+Shift key. 

A marker is set on a 3D surface by a single click on the desired position on the surface (e.g. to specify 
fiducials for coregistration). A marker can be selected by clicking onto it and moved along the surface by 
dragging the mouse. Selected markers can be removed by pressing the Del key.  

The mouse cursor symbol signals the available interaction associated with clicking and/or dragging:  

  Rotate 3D image or set marker. Zoom 3D image. 

 Move 3D image. Select or move marker under cursor. 

 

6.3.4. BESA Research Solution Display 

Loading a solution file 

Press the Load sources button to open a dialog that allows selecting a discrete source solution exported 
from BESA Research. When the solution file is loaded the sources will automatically be displayed; if the 
solution was saved by BESA Research 7.1 or higher in Talairach coordinates, then sources are displayed 
together with confidence ellipsoid and error rim, provided that this information was calculated and saved 
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by BESA Research – see the note below for restrictions. Source positions are automatically adjusted to 
the displayed transformation of MRI data (ACPC or Talairach). 

 

Source type is indicated by symbols: 

 
single dipole  

 
regional source 

 
spatial component 

Note: Sources are not displayed for surface views. 

 

Additional controls 

When sources are displayed, additional controls are available. It is possible to independently disable or 
enable display of Sources, Confidence area and Error rim. The source size can also be adjusted by the 
Sources scale slider. 

Note: Confidence ellipsoid and error rim is only visible for single dipole sources, and requires solutions 
created with BESA Research 7.1 or higher. 

 

Source file format and sources preparation 

Any solution obtained in BESA Research can be exported from there, and displayed in BESA MRI. To 
export a solution from BESA Research use menu File / Save Solution As... in the Source Analysis 
window of BESA Research. When the Save file dialog is open make sure to select BESA Solutions - 
Talairach (*.bsa) file type in the Save as Type drop down menu. From BESA Research 7.1, the source 
confidence will be automatically computed and added to the solution file. For older BESA Research 
versions radii for confidence ellipsoid and error rim are set to default values. 
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CFG file 

The default values for confidence ellipsoid and error rim can be defined in the BESA MRI configuration 
file. Please see the appendix for more details (section 7.4). 

 

Head sphere 

It is also possible to display the spherical model of the MEG for ACPC transformation. If the check box for 
MEG is checked in the section Displayed sphere model (ACPC), the spherical model is displayed as 
transparent overlay. The center of the sphere is indicated by a small circle. 

 

6.3.5. Brain Atlases 

6.3.5.1. Introduction 

A brain atlas is a priori data that can be applied after successfully finishing the segmentation workflow. It 
is a reference value that strongly depends on the selected brain atlas and should not be used as medical 
reference since individual brains may differ from the brain atlas. 

 

Note: Brain Atlases display is only available for Talairach transformation views. 
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In BESA MRI, the atlases listed below are provided. BESA is not the author of the atlases; please cite the 
appropriate publications if you use any of the atlases in your publication. 

Brainnetome This is one of the most modern brain probabilistic atlas where structural, functional, and 
connectivity information was used to perform cortical parcellation. It was introduced by Fan and 
colleagues (2016), and is still work in progress. The atlas was created using data from 40 healthy adults 
taking part in the Human Connectome Project. In March 2018, the atlas consists of 246 structures labeled 
independently for each hemisphere. In BESA we provide the max probability map with labeling. Please 
visit the Brainnetome webpage to see more details related to the indicated brain regions (i.e. behavioral 
domains, paradigm classes and regions connectivity). 

AAL The Automated Anatomical Labeling atlas was created in 2002 by Tzourio-Mazoyer and colleagues 
(2002). It is the mostly used atlas nowadays. The atlas is based on the averaged brain of one subject 
(young male) who was scanned 27 times. The atlas resolution is 1mm isometric. The brain sulci were 
drawn manually on every 2mm slice and then brain regions were automatically assigned. The atlas 
consists of 116 regions which are asymmetrical between hemispheres. The atlas is implemented as in the 
SPM12 toolbox. 

Brodmann. The Brodmann map was created by Brodmann (1909). The brain regions were differentiated 
by cytoarchitecture of each cortical area using the Nissi method of cell staining. The digitization of the 
original Brodmann map was performed by Damasio and Damasio (1989). The digitized atlas consists of 
44 fields that are symmetric between hemispheres. BESA used the atlas implementation as in Chris 
Roden’s MRICro software. 

AAL2015 Automated Anatomical Labeling revision 2015. This is the updated AAL atlas. In comparison to 
the previous version (AAL) mainly the frontal lobe shows a higher degree of parcellation (Rolls et al., 
2015). The atlas is implemented as in the SPM12 toolbox. 

Talairach The Talairach atlas was created in 1988 by Talairach and Tournoux (1988) and it is based on 
the post mortem brain slices of a 60-year old right-handed European female. It was created by drawing 
and matching regions with the Brodmann map. The atlas is available at 5 tissue levels, however we used 
only the volumetric gyrus level as it is the most known in neuroscience and is the most appropriate for 
EEG. The atlas consists of 55 regions that are symmetric between hemispheres. The native resolution of 
the atlas was 0.43x0.43x2-5 mm. Please note that the poor resolution in Z direction is a direct 
consequence of the atlas definition, and since it is a post-mortem atlas it will not correctly match the brain 
template (noticeable mainly on brain edges). The atlas digitization was performed by Lancaster and 
colleagues (2000) resulting in a “golden standard” for neuroscience. The atlas was first implemented in a 
software called Talairach Daemon. 

6.3.5.2. Visualization modes 

When an atlas is shown, the following information is provided in the top right corner of the Transverse 
view: 

• the current cursor position in Talairach Coordinates 

• brain atlas 

• brain region name 

Atlas overlay can be displayed as: 

brainCOLOR. The atlas is visible as an overlay over the MRI. The coloring is performed using the 
algorithm introduced by Klein and colleagues (Klein et al. 2010). With this method of coloring the regions 
which are part of the same lobe are colored in a similar color but with different color shades. The shade is 
computed by the algorithm to make these regions visually differentiable from each other as much as 
possible. 

Individual Color. In this mode the native brain atlas color is used if provided by the authors of the brain 
atlas (i.e. Brainnetome). Where this is not available BESA auto-generates colors for the atlas using an 
approach similar to political map coloring. This approach aims to differentiate most regions that are 
adjacent to each other and no presumptions on lobes is applied. 

Contour. Only region contours (borders between atlas regions) are drawn with blue color. 
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6.3.6. Multi-slice View 

A convenient way to review MRI date and export it in graphical form is a multi-slice view. To enable multi-
slice view check the Use Slice View button. 

 

In this view all additional information can also be displayed (i.e. sources, brain atlas). The display matrix 
can be adjusted by additional controls that are shown after enabling slice view. One of these slicing 
directions can be selected: Transverse, Coronal, Sagittal. By adjusting First slice and Last slice 
sliders, the span of the volume that will be displayed can be adjusted. The interval between slices can be 
adjusted by changing the Spacing slider value. The layout of slices will be automatically adjusted to fill 
the full space of the main window. All values in the sliders are given in mm. 

Note: The last slice value will be adjusted to the closest possible number matching the given first slice 
and spacing value. During multi-slice view the cursor is disabled and no atlas information is provided. 
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6.3.7. View results for a coregistration project 

After opening a finalized project, the project is locked and the View Results work step is shown as the 
screen shot below. 

 

The color of the spheres indicates: 

• Red: sensors 

• Gray: surface points 

• Blue: marked fiducials 

• Pink: fitted fiducials 

• Green: MEG HPI coils 

When you place the mouse pointer over a sphere, the label for the sphere is displayed in the tooltip. 

Scalp surface display can be toggled using the check box Show Scalp Surface. 

When the checkbox Hide Surface Points is checked, only EEG or MEG sensors are shown in the main 
window. 

When the checkbox Show MEG Sensors is checked, MEG sensors are displayed in the main window as 
red circles 

The co-registration file can be exported to a new location using the button Export Coregistration (SFH) 
File. 

At the bottom of the Interaction Window, it is possible to modify the project using the button Modify. This 
will unlock the project and run through the worksteps automatically. 

6.3.8. Save the main window as an image file 

On right-click in the main window, a popup menu appears with Export option. After selecting the “Export” 
option, the “Save Image As…” dialog is shown as the Export Menu (see the chapter 5.5.4). The main 
window can be saved as *.eps, *.png. or *.svg image file format. 
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6.4. Important Dialogs 

This section describes important user interactions realized by dialogs. 

6.4.1. Select the BESA MRI Data Folder 

If required, you may switch to different or create a new BESA MRI Data Folder by selecting the menu 
item File → Select Data Folder. In the dialog box below, select an existing folder to store all result data 
of BESA MRI or create a new folder accessible to all users in your workgroup (see chapter 7.1): 

 

Select a folder in this dialog and press Select Folder to set this folder as the current BESA MRI Data 
Folder. After selecting a new BESA MRI Data Folder, the following confirmation dialog appears: 

 

Press OK to activate the new BESA MRI data folder. 

It is recommended to leave the tick mark on to update all existing projects in the new BESA MRI Data 
folder, if you switch between folders (see chapter 2.1). 

Note: When switching between different BESA MRI Data folders, the project data are preserved in each 
folder and are not copied to the new folder. 

6.4.2. Open Projects 

Projects can be opened by pressing Open Segmentation Project or Open Coregistration Project in 
the Select Project Page (see chapter 6.1.2) or by selecting the menu item File → Open Project. 

The project type to be opened is displayed at the bottom of the Open Project dialog box shown below and 
may be modified using the Project Type dropdown list: 
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Icons in the list of subjects: 

• Green tick mark: All projects of this subject have been finalized. 

• Green circle: All steps have been completed for all projects of this subject, but at least one project 
has not yet been finalized. 

• Yellow circle: All manual steps have been completed, but at least one project is still in progress. 

• Red circle: For at least one project, some manual steps have not yet been completed 

Icons in the list of projects: 

• Green tick mark: The project has been finalized. 

• Green circle: All steps have been computed, but the project has not yet been finalized. 

• Yellow circle: All manual steps have been completed, but the project is still in progress. 

• Red circle: Some manual steps have not yet been completed. 

Projects are stored under subject name and birth date. First, select the desired subject clicking on the left. 
If different projects exist for this subject, select the desired project by clicking on the right. 

Press Open. 

6.4.3. Finish, Save and Close Projects  

6.4.3.1. Finish a project 

The last step in any workflow is finishing the project by typing Space or pressing Finish. This last action 
ensures that the project data with all result files are stored in the BESA MRI Data Folder. 

The “Save Project As…” dialog box comes up proposing a project name if the project is new (see figure 
below). If a previous project has been opened and modified, the previous name is proposed. 

The selected subject and proposed project names are highlighted automatically. To save under a different 
project name, enter a new project name in the Selected Project edit field. 

Press Save to store the project data including all volume and surface data sets. 

If the selected project name does not yet exist, the project is saved with all result files automatically. 
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If you keep the highlighted project name of a previous project or select another previous project name of 
the current subject in the Projects selection box on the right, you will be asked whether to replace the 
previous project by the new project data: 

Press Yes, if you want to discard the previous project data and store the new data under the previous 
project name. 

Press No, if you prefer to save under a different project name. The Save Project As… dialog box comes 
up again. 

This workstep is complete when the Select Projects page comes up again offering to select another 
project or exit the BESA MRI program. 

Note: You may get to the Save Project As… dialog box at any time during the workflow using the menu 
item File → Save As, e.g. if you want to store the current data preparation under a specific project name 
to be completed later by Automatic Finalization. 

6.4.3.2. Close a project 

At any time during the workflow, you may close the current project using the Close button in the toolbar 
or the menu item File → Close. 

When closing a project, the following dialog box comes up: 

Press Yes to save the changed project data. Previously stored data will be overwritten.  
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Press No if you want to discard all changes, e.g. when accidentally modifying user defined parameters 
during reinspection after opening an existing project. In this case, the stored data of the current, 
previously saved project will not be overwritten and changes to the project will not be stored.  

Press Cancel to return to the project workflow, e.g. if you want to save the current changes under a new 
project name using the menu item File → Save As. 

6.4.3.3. Save a project 

At any time during the workflow, data can be saved by selecting the menu item File → Save or typing 
Ctrl+S. However, previously stored data will be overwritten automatically. 

Notes on closing and saving: 

1. Closing and saving can be done at any time during the preparation of a project to preserve the user 
input up to the completed workstep. 

2. If a previously completed project has been opened, previous project data will be overwritten and 
replaced by the current state of the project. Therefore, do not use the save function when opening a 
previous project simply for inspection. In this case, use the menu item File → Save As. 

3. Select the menu item File → Save As to store a modified project under a new project name. 

4. The current project state and name can always be seen in title bar. 

6.4.4. Delete Projects 

Stored BESA MRI projects can be deleted if no longer needed, e.g. if an improved coregistration project 
has made a previous project obsolete. To delete, select the menu item File → Delete Projects…. The 
Delete Projects dialog box appears: 

In the Project Type drop down selection box at the bottom, select the type(s) of projects to be deleted. 
Select Segmentation Projects to delete segmentation projects, Coregistration Projects to delete 
coregistration projects, or All Projects to delete segmentation and coregistration projects. 

Mark all subjects for whom project data shall be deleted in the Subjects selection box. Then select the 
projects to be deleted in the Projects selection box (multiple subjects or projects can be selected by 
holding the Ctrl or Shift key while selecting). 

A confirmation box is displayed, after selecting and pressing Delete. 

Press Yes only, if you do not need the listed project data any more. Restoring is no longer possible after 
deleting. Press No to prevent deleting. 
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6.4.5. Select Files 

When selecting input data, the following dialog appears: 

 

The drop-down menu Files of type allows choosing between DICOM files, DICOM Folder, 
ANALYZE/NIFTI Files, and VMR Files (see also 6.2.1.2). DICOM Folder should be selected if multiple 
scans of the same or different subjects are stored within one folder. 

Use the drop-down folder list at the top to navigate to the desired input folder. Then, select a file in the 
current folder and press Open. 
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7. Appendix 

For an easy data management, the data generated by BESA MRI are stored in one folder. In this folder, 
the so-called BESA MRI Data Folder, the data are organized in subject-based subfolders. 

7.1. The BESA MRI Data Folder 

The BESA MRI Data Folder is the folder or path where BESA MRI stores all project data to and reads 
completed or prepared projects from. This folder should exclusively be used for storing BESA MRI data. 

When starting BESA MRI for the first time (see chapter 2), a local folder accessible to all users is 
suggested as the default folder. Depending on the operating system, this folder is located as follows: 

• Windows 10:   C:\Users\Public\Public Documents\BESA MRI\Projects\ 

• Windows 7:   C:\Users\Public\Public Documents\BESA MRI\Projects\ 

In most cases, however, it might be more useful to create a shared folder on a server drive, e.g. 
E:\Server\BESA MRI Data that is accessible to all users from anywhere in the local network. This is more 
convenient, since BESA MRI uses a network dongle allowing the software to be run from any computer in 
the local network where BESA MRI has been installed and configured with the shared BESA MRI Data 
folder. 

Important note: In clinical use, it is highly recommended using an encrypted drive to store the data 
folder, since it can contain patient information, unless the option to anonymize patient data is used in the 
workflow step of MRI data reading. Furthermore, please ensure that PCs running BESA MRI are 
password-protected such that only eligible users have access to BESA MRI.  

Note: If you have a multi-license installation, make sure that two users do not work on the same subject 
and project at the same time. Currently, BESA MRI does not lock projects within the network. 

If there are several major research studies with different subjects, you might want to create separate 
folders to store the data of the different studies separately. BESA MRI offers the choice to switch between 
different BESA MRI Data folders (see chapter 6.4.1) by selecting the menu item File → Select Data 
Folder. 

Note: When switching between different BESA MRI Data folders, the project data are preserved in each 
folder and are not copied to the new folder. Thus, you may have to segment a subject’s MRI twice unless 
you copy the subject’s subfolder to the new BESA MRI Data folder using, e.g. Windows Explorer, and 
update the Data Folder Information as described below. 

7.2. The BESA MRI Data Folder Information File 

For faster access on the different projects in the BESA MRI Data folder, an information file called Data 
Folder Info is created in the subfolder BesaInternal within each BESA MRI Data folder. The Data Folder 
information stores the subject and project file names of all projects in the BESA MRI Data folder. 

After copying or moving subject data folders from a previous to a new BESA MRI Data folder using, e.g. 
Windows Explorer, update the Data Folder information by selecting the menu item File → Update Data 
Folder Info. When switching between folders, make sure that the tick mark of the update option stays on 
in the confirmation dialog box (see chapter 6.4.1). 
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7.3. Subject-based Data Management 

Project data are stored on a subject name basis. Subjects are identified by family name, first name, and 
birth date as read from the input files (DICOM). If a subject name is not known, e.g. if the MRI data have 
been anonymized, the default subject name Z_Anonym is used. If the birthday is not specified, the 
default birthday 1901-01-01 (Unknown DOB = unknown date of birth) is set. 

All project data of a subject are stored in one subfolder of the BESA MRI Data folder having the 
composed folder name <SubjectName>_<Birthday>. 

Project data are managed by BESA MRI using special dialogs for opening, saving or closing, and deleting 
projects (see chapter 6.4.4). These dialogs provide a subject-and project based selection of completed or 
prepared project data.  

 

7.4. The configuration file 

Some settings can be adjusted in the BESA MRI.cfg file, located in: 

C:\Users\<USER>\Documents\BESA MRI\Settings\BESA MRI.cfg 

 

Default error ellipsoid radius: A new group can be added to the config file (the values provided in the 
example below show the default values): 

[SphereAndError] 

1st=20.000000 

2nd=20.000000 

3rd=20.000000 

ErrorMax=60 

ErrorMin=5 

UseDipoleColorAsDefault=0 

OverrideBSA=0 

 

The values for radii are expressed in mm. The first three values define the radii of ellipsoid and rim. The 
first value (1st) is the primary radius, oriented radially from the source to the head center. The second 

value (2nd) is the secondary radius, whose orientation is a projection of dipole orientation onto the plane 

perpendicular to radial direction. In case that the dipole orientation is also radial, the direction is the x 
direction of the unit sphere coordinate system. However, if the source location lies in x direction, then the 
direction is the z direction of unit sphere coordinate system. The third value (3rd) is the tertiary radius, 

oriented orthogonally to the previous two. 

Maximum and minimum values of the error radii can be set using ErrorMax and ErrorMin, 

respectively. 

When UseDipoleColorAsDefault is set to 1, ellipsoids will be colored using the dipole color instead 

of gray even for cases when default sizes are used. 

If the OverrideBSA is set to 1, the error radii information of the BESA Research solution will be 

discarded and default values will be used instead. 
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Inhomogeneity correction for displayed MRI: If the setting 

[Settings] 

InhomogeneityCorrectionDisplay=0 

is set, then the inhomogeneity correction will not be applied for visualization. The default is 1 (it will be 
applied). 
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